summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordakkar <dakkar@thenautilus.net>2025-02-21 15:38:21 +0000
committerdakkar <dakkar@thenautilus.net>2025-02-21 15:38:21 +0000
commitebfe89d777ad06b495bf6cb806688d155a8e7d33 (patch)
tree642ccba1e94ec887743569f5b9236e16e3bb7095
parentsmartctl_exporter 0.13 (diff)
downloadgentoo-overlay-ebfe89d777ad06b495bf6cb806688d155a8e7d33.tar.gz
gentoo-overlay-ebfe89d777ad06b495bf6cb806688d155a8e7d33.tar.bz2
gentoo-overlay-ebfe89d777ad06b495bf6cb806688d155a8e7d33.zip
pgroonga 4.0.1HEADmaster
-rw-r--r--dev-db/pgroonga/Manifest2
-rw-r--r--dev-db/pgroonga/pgroonga-4.0.1.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-db/pgroonga/Manifest b/dev-db/pgroonga/Manifest
index 78aa033..7000b8a 100644
--- a/dev-db/pgroonga/Manifest
+++ b/dev-db/pgroonga/Manifest
@@ -1,2 +1,4 @@
DIST pgroonga-4.0.0.tar.gz 1616198 BLAKE2B 0870838409f32b17379593bb5e351192028b7923bf628af2b54ec6ef3a2646f18462e1ea118a89417c7328a591f77983646d985acc219a792b8a97f5cb2c52b2 SHA512 8a320af20497a7d7064c3e025e2e6b183a5d198bc9e404363296fc84237144957e7441cda6ea6daf1692f8217c3fd9109c9ca36f48ce302d7417fbd80a05f170
+DIST pgroonga-4.0.1.tar.gz 1609097 BLAKE2B c543fbf64b9fb801c44ef68ded0579b09e1230501f16673b463b18d48cd506697a3fa259a3201e34f8c55084cebcdd1145fc56584057cdf17bf541919ba7d5d5 SHA512 7b6ffd9874472ee2888f363878a737f2cf70956ad3c4e1bdb5b00d63c9a88d5225d623a2dd27d3e0b793e698081eb01f6cf36184dad6e90ec196bdc9b29490de
EBUILD pgroonga-4.0.0.ebuild 620 BLAKE2B 0ef72f7b9cfebcc9ec15202ded6a1db573d80735352fb255f119ec819187d0d7138b2369e7e6edd6c6b5bba0e774007d8484b28720ff4806ee0bf03bd4073b5d SHA512 79adb2fad3a37ba854c02e7c9317f7b873d77558fcd3e8b514df3d21457d3536dbed7733117da3c1869843a30d98f23dbef739080b45dfb46d48de434e997a5d
+EBUILD pgroonga-4.0.1.ebuild 620 BLAKE2B 0ef72f7b9cfebcc9ec15202ded6a1db573d80735352fb255f119ec819187d0d7138b2369e7e6edd6c6b5bba0e774007d8484b28720ff4806ee0bf03bd4073b5d SHA512 79adb2fad3a37ba854c02e7c9317f7b873d77558fcd3e8b514df3d21457d3536dbed7733117da3c1869843a30d98f23dbef739080b45dfb46d48de434e997a5d
diff --git a/dev-db/pgroonga/pgroonga-4.0.1.ebuild b/dev-db/pgroonga/pgroonga-4.0.1.ebuild
new file mode 100644
index 0000000..ab05e54
--- /dev/null
+++ b/dev-db/pgroonga/pgroonga-4.0.1.ebuild
@@ -0,0 +1,30 @@
+EAPI=8
+
+POSTGRES_COMPAT=( {15..17} )
+POSTGRES_USEDEP="server"
+
+inherit postgres-multi
+
+DESCRIPTION="PGroonga full-text search engine"
+HOMEPAGE="https://pgroonga.github.io/"
+LICENSE="POSTGRESQL"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+SRC_URI="https://packages.groonga.org/source/pgroonga/${P}.tar.gz"
+IUSE="msgpack"
+
+RDEPEND="${POSTGRES_DEP}
+ >=app-text/groonga-14.0.0[msgpack?]
+ >=dev-libs/xxhash-0.8.0
+"
+
+DEPEND="${RDEPEND}"
+# maybe? Needs a running psql instance, doesn't work out of the box
+RESTRICT="mirror test"
+
+src_compile() {
+ use msgpack && export HAVE_MSGPACK=1
+ export HAVE_XXHASH=1
+ postgres-multi_foreach emake
+}